USMLE Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi everybody, this is really urgent and I really appreciate any suggestion. I am applying for the step2Ck exam for the first time. every time I complete all the application steps upto the payment part, when I want to pay it sayas "your session has expired". At first I thought it may be because of the time it takes to fill all the application parts so I went to my OASIS acount- financial summery account to pay from there, but even in my OASIS account when I want to pay it says session expired. What should I do? this is really frustrating. I really appreciate any help. Thank you.
 

·
Registered
Joined
·
132 Posts
Have you tried to make this application from another internet connection? Or
you could give them a call, probably they will know what you should do. You will need a lot of patience though, because ECFMG has a lot of calls these weeks and you probably have to wait in the line for some time.

Good luck
 

·
Registered
Joined
·
373 Posts
I think the problem is in ur Internet browser settings. Make sure u have enabled accept cookies option in the security settings.
 
  • Like
Reactions: drn3

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Thank you Sadalssud and Step1 an for your comments. I did what you said and still I got the same messeage. Finally, I borrowed my friends laptop and finished my application without any problems. I dont know much about computer stuff and I cant understand whats wrong with my PC. But I am happy the online application part is over :)
 

·
Registered
Joined
·
1 Posts
Hi everybody, i am having the same problem with my step 1 application. It was going smooth until I reached the payment page and it said session expired. I tried multiple times, even logged in again and refreshed, and started a new application but got the same message. It is really frustrating! I hope the account isn't locked? I have already emailed them. Any help would be appreciated. Thank you.
 
1 - 5 of 5 Posts
Top